How can we help?

Which browsers do Prepare support?

Prepare supports all the latest versions of the following browsers:
Google Chrome, Microsoft Edge, Apple Safari, Mozilla Firefox and Internet Explorer version 11.

We are recommending Google Chrome 

Sometimes, errors and unexpected user scenarios may occur for you, if you are using Internet Explorer 10 or older versions, when you login to Prepare. That's because Microsoft, since January 2016, no longer develop or maintain older versions of Internet Explorer. Generally is Internet Explorer way behind in development and security, compared to other the other browsers.

We therefore recommend that you use a different and safer browser than Internet Explorer. For example, Google Chrome or Firefox, which are the browsers that in general have the fewest issues.

Download Google Chrome for free.

Remember: Always make sure that your browser is updated to the latest version, so you have the latest security updates.

Check which browser you are using

Hvor godt besvarede denne artikel dit spørgsmål?

Hvordan kan vi gøre det bedre?